Technical problems

I am using firefox. Clicking on a topic often won’t take me to the thread. It sometimes works if I click ’ open link in new tab’ but other times I get a blank white page apart from the schizophrenia.com logo.Also often clicking on the schizophrenia.com logo doesn’t work.
Can take me ages to be able to read a thread …

1 Like

Maybe try clearing your cache and cookies.

This post was flagged by the community and is temporarily hidden.

Sometimes this happens on my computer. I tend to have a lot of windows open and leave my computer on for long periods. Sometimes rebooting your computer can help a lot.

I have the worst experience with Discourse using Android 4.x default browser where I cannot go to forum homepage after tapping the logo button, and scrolling is particulary difficult. IE11, Firefox, Chrome, Safari, so far are okay with this site. I am not sure what’s the name of the default browser came with Android.

That seems to have worked.

1 Like

Still getting the problem have tried deleting cookies for the site again but it makes no difference… Things will work fine for a few hours and then problems